Diadu Forum

Author Topic: Trails of Cold Steel  (Read 5743 times)

Diadu

  • Administrator
  • Jr. Member
  • *****
  • Posts: 81
  • Karma: +1/-1
    • diadu_
    • View Profile
Trails of Cold Steel
« on: July 24, 2018, 03:09:56 AM »
I picked it up by mere chance a couple of months ago and gave it a try and it's surprisingly good. At first the story sounds like the average stuff you've heard a dozen times before, military, empire, nobles, commoners blahblahblah and in the first hour or so it sounds pretty average and dull but the story and setting are presented in a pretty interesting way.

The game isn't open world and usually you are bound to one location which usually consists of a hub or two with shops and NPCs and a few dungeons which usually are roads that, in story terms, lead to other places.

I feel that, while the story and character interactions are it's biggest asset it also seems to be the game's weakest point. I know that there is a direct sequel out there and after I was halfway through the game, I just knew that not all the questions that are being raised will be answered within the game. And the next problem is that there already is a 3rd game, which also acts as a direct sequel, which still has no western release date set. As far as I read, Falcom doesn't want XSEED/Marvelous to do the localization anymore (I don't really want to ask XSEED about it though, feels kinda bad) so people worry that NISA might be doing it, which will probably be very terrible.

Despite that, they are pretty good games and if you are on the fence about them, go ahead and get them. As far as I know they are also available on PC.

MarvinGek

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Trails of Cold Steel
« Reply #1 on: February 17, 2019, 11:32:29 PM »
On a whim I tried this game on the newest build
rpcs3-v0.0.2-2017-05-26-7739f332_win64

Miraculously it worked. After a short install of game data, I was able to see the opening intro and was able to start a new game before it got stuck on infinite loading.

Attached is the log file.

I could only try it on D3D12 since my OpenGL doesnt work anymore on the newest builds. Now usually my crappy video card shoots down my hopes of playing these games because Trails of Cold Steel 1 doesnt work for me. But maybe Im just missing a little thing here to get this to work?